315/ 75/ 16 on an 80

fbnss

Well-Known Member
Supporter
I am in england
Oct 14, 2013
2,836
1,967
113
Watford, United Kingdom, United Kingdom
So I finally got some new bfg km3's and after picking up some shiny new wheels from @karl webster last weekend got the tyre fitter at work to stick them on the rims yesterday. Took them home and
20190525_143059.jpg
20190525_141543.jpg

now annoyingly i snapped twp studs on one wheel :rage:
20190525_134758.jpg

so after speaking with the ever helpful Karl set about dismantling the nsf hub to change them over with spares i had in the boot, after a voyage of discovery and a quick phonecall to @Trevor when id forgotten how to do something they were swopped over :)
reassembled everything and ping! one of the new studs snapped again. I think these were the same as the dodgy batch that @grantw had a while ago.
 

Shayne

Well-Known Member
Guru
Feb 2, 2013
13,346
5,035
113
South Wales UK
Looks good mate and count your blessings the studs snapped at home huh .

While people are posting suggestions about where to source studs i will be asking soon where to get +10mm studs ?
 
Don't like the adverts? Remove them by becoming a supporting member.   Click here

Chris

Super Moderator
Supporter
I am in europe
Feb 24, 2010
17,170
3,937
113
Chesterfield, Derbyshire
Garage
Before the Russia trip I replaced all of my studs with genuine OEM Mr T ones. I just felt that the number of times my rims had been on and off and the work they'd done, there was a good chance of failure at some point. All new nuts too. And despite it being really easy, I never torque them up with the impact gun.
 

fbnss

Well-Known Member
Supporter
I am in england
Oct 14, 2013
2,836
1,967
113
Watford, United Kingdom, United Kingdom
Just picked some genuine ones up at Karl's, will be getting some more to replace others at some point.
Rich, ive only driven it to the end of the drive and turned around. No rubbing anywhere but no idea when theres some articulation. I was measuring my speedo with an app the other day and on 285s it was reading 2 mph over what the gps was saying. Will update when I drive somewhere with the bigguns on :)
 

Gary820

Well-Known Member
I am in great_britain
Jan 8, 2013
3,043
1,302
113
York
Garage
Looks good, shame about the studs breaking.

My speedo is 2mph under compared to gps with the 35's on.
 
  • Like
Reactions: fbnss

fbnss

Well-Known Member
Supporter
I am in england
Oct 14, 2013
2,836
1,967
113
Watford, United Kingdom, United Kingdom
Before the Russia trip I replaced all of my studs with genuine OEM Mr T ones. I just felt that the number of times my rims had been on and off and the work they'd done, there was a good chance of failure at some point. All new nuts too. And despite it being really easy, I never torque them up with the impact gun.
I was using a torque wrench but it didnt seem to like it, might dig the actual wheel nut tightener thingy out the toolkit to do it in future
 

fbnss

Well-Known Member
Supporter
I am in england
Oct 14, 2013
2,836
1,967
113
Watford, United Kingdom, United Kingdom
Ita all back together and nothing has gone ping :) I used the wheel brace this time and will recheck after I've driven it a bit. Just have to bleed the brakes now as the rough trax brake lines go straight across one of the caliper bolts so had to undo it
 
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks