Land Cruiser 150 D4D Auto Fuel Filter Light

RC150

New Member
I am in great_britain
Oct 23, 2019
9
4
3
Hi Chaps,

I’ve got a fuel filter maintenance warning on the 150; I’ve drained the filter in case it was water in it (it wasnt), and have a new filter, but don’t know how to get the cruiser to reset the warning; does anyone know how to reset it? It’s the Icon, auto box, push to start.

advice welcome!

cheers,

Russ
 

Crispin

Administrator
Staff member
Guru
I am in great_britain
Feb 24, 2010
5,967
574
113
springs, gauteng
It's normally automatically reset. There is a plug on or near the water trap, is that disconnected? Try reseat it?
 

Juddian

Active Member
I am in great_britain
Jun 17, 2019
90
75
18
Kettering, Northamptonshire
Arn't filter lights a float design? so if there's water present the float will rise and make contact.
You should be able to check the current with a simple test light, maybe the contacts have got corroded or the float's stuck at the top of its travel.

Are you Geoff Capes by the way, push starting a LC is impressive :icon-twisted:
 
  • Like
Reactions: RC150
Don't like the adverts? Remove them by becoming a supporting member.   Click here

RC150

New Member
I am in great_britain
Oct 23, 2019
9
4
3
Arn't filter lights a float design? so if there's water present the float will rise and make contact.
You should be able to check the current with a simple test light, maybe the contacts have got corroded or the float's stuck at the top of its travel.

Are you Geoff Capes by the way, push starting a LC is impressive :icon-twisted:
Thanks, Juddian, will also check this.

Haha! I can push start it with a finger, so perhaps
 
  • Like
Reactions: Juddian

Gasmanjc

Member
I am in australia
Oct 11, 2016
180
115
43
Gold Coast
Hi RC150 not sure if you solved this yet. When I did mine I unplugged the top sensor started the vehicle , plugged the sensor back in , turned off the vehicle. Started again and warning lamp was cleared.
 

RC150

New Member
I am in great_britain
Oct 23, 2019
9
4
3
Hi Gasmanjc, I tried this plus everything else, no dice. Looks like the sensor must be bust, it’s the only thing left to change.
 
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks